AWS on eclipse 2019-03

On this post I share the details that I use for installing AWS on the eclipse 2019-0, using Ubuntu 16.04.6

  1. Use the “Ubuntu Software” app to install Eclipse 2019-03, directly from the main Ubuntu repo
  2. Do not look for AWS in the Eclipse marketplace it won’t work if you install it from there, you will experience an error like: https://github.com/aws/aws-toolkit-eclipse/issues/144

Cannot complete the install because one or more required items could not be found. Software currently installed: Amazon RDS Management 1.0.0.v201807201743 (com.amazonaws.eclipse.rds.feature.feature.group 1.0.0.v201807201743) Missing requirement: Amazon Relational Database Service (RDS) Plugin 1.0.0.v201807201743 (com.amazonaws.eclipse.rds 1.0.0.v201807201743) requires 'osgi.bundle; org.eclipse.datatools.connectivity.ui.dse 1.1.0' but it could not be found Cannot satisfy dependency: From: Amazon RDS Management 1.0.0.v201807201743 (com.amazonaws.eclipse.rds.feature.feature.group 1.0.0.v201807201743) To: org.eclipse.equinox.p2.iu; com.amazonaws.eclipse.rds [1.0.0.v201807201743,1.0.0.v201807201743]

  1. To correctly install AWS for eclipse follow the steps that I am documenting here but are also available at: https://aws.amazon.com/eclipse/

  2. Open Help, Install New Software…
  3. Enter https://aws.amazon.com/eclipse in the text box Work with: enter AWS Core for a name
  4. Select the required “AWS Core Management Tools” and any prefered add on: AWS Deployment tools and AWS Developer tools are some good add ons.
  5. Click “Next.”